const regex = /^((\+\d{1,3})?\(\d{2,3}\))?\d{4,5}-\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\+\\d{1,3})?\\(\\d{2,3}\\))?\\d{4,5}-\\d{4}$', 'gm')
const str = `00000-000
0000-000
00000-0000
07625-034
88756-9039
(11)55554-5555
+55(11)5555-5555
33085-098
+000(00)0000-0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}