#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([0-9]+)/([0-9]+)/([0-9a-zA-Z_-]+)/([0-9]+)/(thumbnail+)/([0-9a-zA-Z\-\_]+)(\.jpg)$"
Local $sString = "1530778610/2018/Jul/05/thumbnail/lake-u_8610.jpg" & @CRLF & _
"1530778610/2018/Jul/05/thumbnail/lakeu_8610.jpg"
Local $sSubst = "/upload/$2/$3/$4/$1_sm.jpg"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)