import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]+)/([0-9]+)/([0-9a-zA-Z_-]+)/([0-9]+)/(thumbnail+)/([0-9a-zA-Z\\-\\_]+)(\\.jpg)$";
final String string = "1530778610/2018/Jul/05/thumbnail/lake-u_8610.jpg\n"
+ "1530778610/2018/Jul/05/thumbnail/lakeu_8610.jpg";
final String subst = "/upload/$2/$3/$4/$1_sm.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}