re = /(?(?=((?<=\d\s))*)(\d+\s)*)(абв)(?=(\s\d+)*)/
str = '123 абв 123 абв абв 123 абв'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end