import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,4}).(\\d{1,4}).(\\s?\\d{4})";
final String string = "Juan Ponce de León sights Florida for the first time, on 3.27, 1513\n"
+ "Giovanni da Verrazzano explored the Atlantic coast of North America under French employ, on 4.17.1524\n"
+ "The Roanoke Colony was found deserted, on 8/15/1590\n"
+ "John Smith founded the Jamestown settlement, on 5/14, 1607\n"
+ "The Dutch laid claim to the territories of New Netherland, on 11.11.1614\n"
+ "The Massachusetts Bay Colony founded, on 3-4-1629";
final String subst = "$3-$1-$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}