$re = '/(s\d+e\d+|s\d+ complete)/m';
$str = 'hello world s01e01.nzb,
hello world S01E01.nzb
hello world s01 complete.nzb
hello world s01e11.nzb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);