$re = '/(?:([a-zA-Z]+|)\d+([a-zA-Z]+|))/';
$str = 'a1b2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);