$re = '/(?<=Python\s).*?(?=\s+words)/s';
$str = 'This is a test to see if I can get Python to print out all the words in between Python and words';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);