$re = '/([^.]*)\">$/m';
$str = '$this$ $is$ $a$ ytreh.test">
<GuiSettings Plugin="Questions.Tab.Tab">
<GuiSettings Plugin="AlteryxGuiToolkit.Questions.Tab.Tab">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);