use strict;
my $str = '[2024-05-19 22:25:53,852] [INFO] [paperless.auth] Login failed for user `sasas` from private IP `192.168.60.1`.';
my $regex = qr/\[.*\] \[INFO\] \[paperless\.auth\] Login failed for user `.*` from IP `<HOST>`/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}