Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
@"
(?<type>[A-Z]{1})(?<subtype>[A-Z<]{1})(?<issue_country>[A-Z]{3})(?<doc_number>[A-Z0-9<]{9})(?<check_sum>[0-9]{1})(?<first_optional>[A-Z0-9<]{15})\n(?<date_brith>[0-9]{6})(?<birth_check>[0-9{1}])(?<sex>[MF]{1})(?<expiration_date>[0-9]{6})(?<expiration_check>[0-9]{1})(?<nationality>[A-Z]{3})(?<second_optional>[A-Z0-9<]{11})(?<check_digit>[0-9]{1})\n(?<lname>[A-Z]+)(?<lname2><[A-Z]+){0,}<<(?<spacing>[<]{0,})(?<fname>[A-Z]+)(?<mname1><[A-Z]+){0,}(?<complement><.+){0,}
"
g
Input 1
1
New
IDCHES0002068<8<<<<<<<<<<<<<<< 8102287F1301014CHE<<<<<<<<<<<4 VADIS<<QUO<<<<<<<<<<<<<<<<<<<< I<NLDXI020DF236123456783<<<<<< 7208148F1108268NLD<<<<<<<<<<<9 VAN<DER<STEEN<<MARIANNE<LOUISE