package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?<days>\d+)\sDays?\s?)?((?<hours>\d+)\sHours?\s?)?((?<minutes>\d+)\sMinutes?\s?)?`)
var str = `1 Hour
10 Hours 47 Minutes
1 Day 5 Hours 15 Minutes
45 Minutes
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}