$re = '/(?: (\w*)=)(?:\"(\w*)\")/m';
$str = 'bla word1="word2" blabla abc="xyz" bla bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);