const regex = new RegExp('([ab]+)|(.+?)', 'gm')
const str = `bbccaa`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);