const regex = /Billing Package for:(\w{3})\s-\sBL:(\w+)\s+TRANSID:(\d+)\s+-\s+(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Billing Package for:(\\w{3})\\s-\\sBL:(\\w+)\\s+TRANSID:(\\d+)\\s+-\\s+(.+)', 'gm')
const str = `[EXTERNAL] Billing Package for:BOR - BL:N5227095 TRANSID:94331 - Darin Jones`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}