re = /Billing Package for:(\w{3})\s-\sBL:(\w+)\s+TRANSID:(\d+)\s+-\s+(.+)/m
str = '[EXTERNAL] Billing Package for:BOR - BL:N5227095 TRANSID:94331 - Darin Jones'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end