// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Billing Package for:(\w{3})\s-\sBL:(\w+)\s+TRANSID:(\d+)\s+-\s+(.+)").unwrap();
let string = "[EXTERNAL] Billing Package for:BOR - BL:N5227095 TRANSID:94331 - Darin Jones";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}