# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?:\\/\\/yadi\.sk\\/\S+)/[link]\1[\/link]/gm;t' <<< "https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd "