use strict;
my $str = 'https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd ';
my $regex = qr/(https?:\/\/yadi\.sk\/\S+)/mp;
my $subst = '[link]\\1[/link]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";