re = /(?<!test)h\w+?\.?\w+@gmail\.com/m
str = 'harry.potter@gmail.com
hagrid@gmail.com
testhermione@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end