$re = '/^deck\s*:?\s*(?<deckname>.*)/mi';
$str = 'deck: Base A
Deck: Base A
deck: Base A
DECK : Base A
deck BASE A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);