import Foundation
let pattern = #"\b(?:\w[\w']* [^a-zA-Z]*){3} ?\([A-Z]{3}\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The task of automatically extracting acronymdefinition pairs from biomedical literature has Most common mis'take (MCM) been studied, almost exclusively for English, over the past few decades using technologies from Natural Language Processing (NLP). This section 167 presents a few approaches and techniques that were applied to the acronym identification task. Taghva and Gilbreth (1999) present the Acronyms 7'- $ **** Finding Program is (AFP), based on pattern matching. Their program seeks for acronym candidates which appear as upper case words. They calculate a heuristic score for each competing definition by classifying words into: (1) stop words (”the”, ”of”, ”and”), (2) hyphenated words (3) normal words (words that don’t fall into any of the above categories) and (4) the acronyms themselves (since an acronym can sometimes be a part of the definition). The AFP utilizes the Longest Common Subsequence (LCS) algorithm (Hunt and Szymanski, 1977) to find all possible alignments of the acronym to the text, followed by simple scoring rules which are based on matches. The performance reported from their experiment are: recall of 86% at precision of 98%
light amplification by stimulated emission of radiation (LASER)
Green Skill Development Programme (GSDP)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)