#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\w\.)(\s\w+\sJ?r?\.?)*(\w+[\sI\,\sJSr.]{0,5})$"
Local $sString = "H. Graham Motion" & @CRLF & _
"T. James Kelly" & @CRLF & _
"J. Palacios Moli" & @CRLF & _
"A. Chadwick Box" & @CRLF & _
"H. Graham Motion III" & @CRLF & _
"T. James Kelly, Jr." & @CRLF & _
"H. Graham Motion II" & @CRLF & _
"V. Barboza Jr."
Local $sSubst = "\1 \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)