use strict;
my $str = '"C:\\Windows\\system32\\NOTEPAD.EXE" C:\\!\\inal11404 -дла оощ ыф цумщлзкщл3з мц ацул MNNMMMqpl v23 953 53262v32 - копия (2) - копия.log';
my $regex = qr/^".*?"/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";