import Foundation
let pattern = #"(?<!\?)>([А-яҐґІіЇїЄє .\-!?]+)<(?!\?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
<div class="faq__wrapper">
<div class="faq__subject faq__subject--active">
<div class="faq__header">
<h1 class="heading-light faq__title">Часті питання</h1>
</div>
<div class="nav nav_faq faq__nav">
<button class="btn-nav nav__link btn-nav--active">
<i class="icon-info icon-info_heart">
<svg>
<use xlink:href="#svg-icon-icon_heart_default"></use>
</svg>
</i>
<span>щодо проекту</span>
</button>
<button class="btn-nav nav__link">
<i class="icon-info icon-info_person">
<svg>
<use xlink:href="#svg-icon-icon_person"></use>
</svg>
</i>
<span>щодо волонтерства</span>
<?=__('Театр')?>
</button>
</div>
</div>
<div class="heading-linked">
<?=__('Зараз у репертуарі ')?><?=$this->plural($performancesCount,
[__('театру'), __('театру'), __('театру')])?> <br/>
<?=$performancesCount?> <?=$this->plural($performancesCount,
[__('вистава'), __('вистави'), __('вистав')])?>
</div>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)