package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\+[0-9]*)\s(\([0-9]*\)\s[0-9]{3}\s[0-9]{2}-[0-9]{2})`)
var str = `+90 (555) 555 55-55
+190 (555) 555 55-55
+1 (555) 555 55-55`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}