import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[^][]*](*SKIP)(*F)|(?:https?://)?(?:www\\.)?[\\w@:%.+~#=]{2,256}\\.[a-z]{2,6}\\b[\\w-@:%+.~#?&/=]*";
final String string = "www.example.com \n"
+ "http://example.com.nz \n"
+ "example.com\n"
+ "http://www.example.com?2rjl6\n"
+ "example.com/first/second\n"
+ "https://example.us.edi?34535/534534?dfg=g&fg\n\n"
+ "etc...\n"
+ "I want no match if any of the above URLs are enclosed in square brackets [ ] like this:\n\n"
+ "[www.example.com]\n"
+ "[http://example.com.nz]\n"
+ "etc...\n\n"
+ ".aaaa\n\n"
+ "e.g.\n\n"
+ "Lorem ipsum dolor sit amet, consectetur [http://example.com.nz] llamcorper et lacus. Morbi sodales convallis lectus a efficitur: example.com/first/second vitae nisl placerat.\n\n"
+ "Fusce non ipsum a augue http://example.com.nz http://www.example.com?2rjl6 aculis augue. Nullam eu nulla lectus.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}