const regex = new RegExp('\\[[^][]*](*SKIP)(*F)|(?:https?://)?(?:www\\.)?[\\w@:%.+~#=]{2,256}\\.[a-z]{2,6}\\b[\\w-@:%+.~#?&/=]*', 'gm')
const str = `www.example.com
http://example.com.nz
example.com
http://www.example.com?2rjl6
example.com/first/second
https://example.us.edi?34535/534534?dfg=g&fg
etc...
I want no match if any of the above URLs are enclosed in square brackets [ ] like this:
[www.example.com]
[http://example.com.nz]
etc...
.aaaa
e.g.
Lorem ipsum dolor sit amet, consectetur [http://example.com.nz] llamcorper et lacus. Morbi sodales convallis lectus a efficitur: example.com/first/second vitae nisl placerat.
Fusce non ipsum a augue http://example.com.nz http://www.example.com?2rjl6 aculis augue. Nullam eu nulla lectus.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}