import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\"(?<name>\\w+Message)\"(,\"(\\w+Message)\")*,function\\([\\w,]*\\)\\{.*?\\}\\)";
final String string = "(\"aaMessage\",\"sdfsdfMessage\",\"sdfsdfMessage\",function(e){})";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}