$re = '/(?(DEFINE)
(?<token>What\sis|plus|minus|multiplied\sby|divided\sby)
)
^\g<token>(?:\s+\g<token>)*$/mx';
$str = 'What is plus divided by
What is 5 plus 2 divided by 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);