re = /(?(DEFINE)
(?<token>What\sis|plus|minus|multiplied\sby|divided\sby)
)
^\g<token>(?:\s+\g<token>)*$/mx
str = 'What is plus divided by
What is 5 plus 2 divided by 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end