import Foundation
let pattern = #"'\K\.(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"$array = ['.1','1.5','0.10','.8'....];"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)