$re = '/(\d{4})(?:-(\d{2})(?:-(\d{2}))?)?(?:\s(.+))?
/m';
$str = '2021 abc
2021-02 abc
2021-02-30
2021
2021-02
2021-02-30 abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);