using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s).*?(?:(?=([DKE])((?!\1)[DKE])([DKE])([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?))(\9\8\7\6\5\4\3\2\1|\7\6\5\4\3\2\1|\5\4\3\2\1|\3\2\1))";
string substitution = @"$10\n";
string input = @"KEKEKEKD
abaabadfkfdDKEKDDEDDD
KEK
DKEKD
DED
DKEKDKEKD
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}