$re = '/(?s).*?(?:(?=([DKE])((?!\1)[DKE])([DKE])([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?))(\9\8\7\6\5\4\3\2\1|\7\6\5\4\3\2\1|\5\4\3\2\1|\3\2\1))/m';
$str = 'KEKEKEKD
abaabadfkfdDKEKDDEDDD
KEK
DKEKD
DED
DKEKDKEKD
';
$subst = "$10\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;