import Foundation
let pattern = #"(?s).*?(?:(?=([DKE])((?!\1)[DKE])([DKE])([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?))(\9\8\7\6\5\4\3\2\1|\7\6\5\4\3\2\1|\5\4\3\2\1|\3\2\1))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
KEKEKEKD
abaabadfkfdDKEKDDEDDD
KEK
DKEKD
DED
DKEKDKEKD
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$10\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)