use strict;
my $str = 'I have a string: prawy p pęknięty p zderzak pęknięcie (it\'s Polish language)
I want to select all p (except "p" in words "pęknięty" and "peknięcie")
I\'ve tried to do something like that: \\b(s*ps*)\\b, but it doesn\'t work properly. Any ideas?
';
my $regex = qr/\bp(?!ęknięty\b|ęknięcie\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}