import Foundation
let pattern = #"\bp(?!ęknięty\b|ęknięcie\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I have a string: prawy p pęknięty p zderzak pęknięcie (it's Polish language)
I want to select all p (except "p" in words "pęknięty" and "peknięcie")
I've tried to do something like that: \b(s*ps*)\b, but it doesn't work properly. Any ideas?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)