#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(The\s)?(cat\s)?(sat\s)?(on\s)?(the\s)?(mat\.)?"
Local $sString = "The cat sat on the mat." & @CRLF & _
"The cat sat on the mat" & @CRLF & _
"The cat sat on teh mat." & @CRLF & _
"The kat sat on the mat." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")