const regex = /^(The\s)?(cat\s)?(sat\s)?(on\s)?(the\s)?(mat\.)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(The\\s)?(cat\\s)?(sat\\s)?(on\\s)?(the\\s)?(mat\\.)?', 'gm')
const str = `The cat sat on the mat.
The cat sat on the mat
The cat sat on teh mat.
The kat sat on the mat.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}