re = /http(s?)(:\/\/)((www.)?)([a-zA-z0-9\-_]+)(.com)/m
str = 'https://exam-ple.com
http://exam_ple.com
https://www.ex-amp_le.com
http://www.ex_am-ple.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end