import Foundation
let pattern = #"\b(?!(\d)\1{3})[13-9]{4}[1346-9][013-9]{5}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1345678939 all not same; 1st 4 not same, 5th digit not 5, all digits
3333333333 all are same
4444151617 1st 4 are same
3167518888 5th digit = 5
9876877772 contains a 2
9876870773 contains a 0 in last 5 digits
9870677665 contains a 0 in first 5 digits
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)