import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "simulate\\(\\w+, \\{\\n\\s+type: \"(\\w+)\",\\n\\s+target: \"\\[data-test-id=([\\w-]+)\\]\",\\n\\s+\\}\\);";
final String string = " simulate(component, {\n"
+ " type: \"click\",\n"
+ " target: \"[data-test-id=filterMenu-owner]\",\n"
+ " });\n\n"
+ " simulate(component, {\n"
+ " type: \"click\",\n"
+ " target: \"[data-test-id=filterMenu-ownerUser]\",\n"
+ " });\n\n"
+ " simulate(filterMenuPopup, {\n"
+ " type: \"click\",\n"
+ " target: \"[data-test-id=filterMenu-author]\",\n"
+ " });\n";
final String subst = "userEvent.$1(screen.getByTestId(\"$2\"))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}