package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)SWEL(?:_Revised|_vendor)?\.js`)
var str = `SWEL_vendor.js`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}