#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?\d*?\.\d+$"
Local $sString = ".01444" & @CRLF & _
"10.454" & @CRLF & _
"4.0O0" & @CRLF & _
"-1.00" & @CRLF & _
"+4.54" & @CRLF & _
"SomeRandomStuffand" & @CRLF & _
"1.0df0" & @CRLF & _
"10.0cv" & @CRLF & _
"1.aada" & @CRLF & _
"4+1.00254" & @CRLF & _
"0.5.0" & @CRLF & _
"+9>>10" & @CRLF & _
"9.7" & @CRLF & _
"1>>3" & @CRLF & _
"-2.4" & @CRLF & _
"-9<<9" & @CRLF & _
"+10.7" & @CRLF & _
"+2<<5" & @CRLF & _
"5.5" & @CRLF & _
"4<<8" & @CRLF & _
"-8.5" & @CRLF & _
"-7>>9" & @CRLF & _
"+9.50" & @CRLF & _
"1.h" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")