import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?\\d*?\\.\\d+$";
final String string = ".01444\n"
+ "10.454\n"
+ "4.0O0\n"
+ "-1.00\n"
+ "+4.54\n"
+ "SomeRandomStuffand\n"
+ "1.0df0\n"
+ "10.0cv\n"
+ "1.aada\n"
+ "4+1.00254\n"
+ "0.5.0\n"
+ "+9>>10\n"
+ "9.7\n"
+ "1>>3\n"
+ "-2.4\n"
+ "-9<<9\n"
+ "+10.7\n"
+ "+2<<5\n"
+ "5.5\n"
+ "4<<8\n"
+ "-8.5\n"
+ "-7>>9\n"
+ "+9.50\n"
+ "1.h\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}