re = /^[+-]?\d*?\.\d+$/m
str = '.01444
10.454
4.0O0
-1.00
+4.54
SomeRandomStuffand
1.0df0
10.0cv
1.aada
4+1.00254
0.5.0
+9>>10
9.7
1>>3
-2.4
-9<<9
+10.7
+2<<5
5.5
4<<8
-8.5
-7>>9
+9.50
1.h
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end