import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(\\s))([0-9]{1,2})\\b(?!\\s*(:|am|pm|from|to|minutes|minute|min|mins))";
final String string = "turn the heating on from 5 mins to 1 am until 10 mins to 2pm\n"
+ "turn the heating on from 1 until 2\n"
+ "turn the heating on from 5 to 1 until 10 to 2\n"
+ "turn the heating on from 5 mins to 1 until 10 mins to 2\n"
+ "turn the heating on from 5 mins to 1 in the the morning\n"
+ "turn the heating on from 5 mins to 1:00 until 10 mins to 2:00\n"
+ "turn the heating on from 5 mins to 1:00 until 10 mins to 2\n"
+ "turn the heating on until 3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}