const regex = /(?<=(\s))([0-9]{1,2})\b(?!\s*(:|am|pm|from|to|minutes|minute|min|mins))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(\\s))([0-9]{1,2})\\b(?!\\s*(:|am|pm|from|to|minutes|minute|min|mins))', 'gi')
const str = `turn the heating on from 5 mins to 1 am until 10 mins to 2pm
turn the heating on from 1 until 2
turn the heating on from 5 to 1 until 10 to 2
turn the heating on from 5 mins to 1 until 10 mins to 2
turn the heating on from 5 mins to 1 in the the morning
turn the heating on from 5 mins to 1:00 until 10 mins to 2:00
turn the heating on from 5 mins to 1:00 until 10 mins to 2
turn the heating on until 3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}