$re = '/(?<=(\s))([0-9]{1,2})\b(?!\s*(:|am|pm|from|to|minutes|minute|min|mins))/i';
$str = 'turn the heating on from 5 mins to 1 am until 10 mins to 2pm
turn the heating on from 1 until 2
turn the heating on from 5 to 1 until 10 to 2
turn the heating on from 5 mins to 1 until 10 mins to 2
turn the heating on from 5 mins to 1 in the the morning
turn the heating on from 5 mins to 1:00 until 10 mins to 2:00
turn the heating on from 5 mins to 1:00 until 10 mins to 2
turn the heating on until 3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);